iVend Mobile POS is Now Compatible with iOS 14

We strive to bring the latest technology – whether it be hardware or software to our clients – and we are therefore pleased to announce that iVend Mobile POS Version 5.3 is now compatible with iOS 14.

Customers using iVend Mobile POS can now upgrade their iOS devices to the versions listed below and update their iVend Mobile POS app from the App Store.

Device and version compatibility details for iPhone and iPad:

  • iPhone (SE), iOS (14.0.1) & iVend Retail MPOS application 5.3
  • iPad (5th generation), iOS (14.0) & iVend Retail MPOS application 5.2
  • The new iVend Mobile POS App will only work with iVend 6.6 and above
Manish Chaturvedi

Manish Chaturvedi

Vice President – Product Marketing



Please fill the form below: